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Preface 
 

In the field of Structural Engineering, computer aided design and drafting software plays an 

important role to assist in the modeling, analysis, design and documentation of structures. They 

improve the quality, efficiency of design through optimization which is time consuming by 

hand calculation. They also mobilize communication through quick documentation.  

This lab manual intends to teach the students the applications of computer softwares in 

structural design and analysis which, in this case consist of ETABS and SAP2000. The basics 

of pre-processing, processing and post-processing units, which are the fundamentals for most 

of the finite element softwares, are also under the purview of this course. In order to prepare 

this manual, help from the course materials of an equivalent course taught at Bangladesh 

University of Engineering and Technology (BUET) and the user manual of concerned software 

were taken.  

 

Shovona Khusru         Shafiqul Islam 

Debasish Sen              Wahid Hassan 

Mehsam Tanzim Khan Mithun Debnath 

 

Department of Civil Engineering 

Ahsanullah University of Science and Technology 

 
 

 

 

 

 

 

 

 

 

 

 



Department of Civil Engineering 
AUST 

 

 
CE 418: Computer Aided Analysis and Design  
 

 

 

Contents 

Fundamentals of the Finite Element Method ............................................................................. 1 

FEA Software in General and ETABS ...................................................................................... 7 

Introduction to ETABS’s User Interface ................................................................................... 8 

Methodology of Finite Element Software.................................................................................. 9 

Basic Workflow ......................................................................................................................... 9 

New Model Initialization ......................................................................................................... 10 

Define Material Properties and Frame Section ........................................................................ 11 

Beam Modeling ........................................................................................................................ 12 

Frame Modeling ....................................................................................................................... 13 

Slab Modeling .......................................................................................................................... 15 

Modeling and Analysis of a Building ...................................................................................... 23 

Design of a Building ................................................................................................................ 32 

Shear Wall Modeling ............................................................................................................... 37 

Design of Water Tank .............................................................................................................. 42 

References ................................................................................................................................ 48 

 

 

 

 

 

 

 



Department of Civil Engineering 
AUST 

 

 

CE 418: Computer Aided Analysis and Design Page 1 
 

Fundamentals of the Finite Element Method 

History and Introduction 

The finite element analysis is a numerical technique. In this method all the complexities of the problems, 

like varying shape, boundary conditions and loads are maintained as they are but the solutions obtained 

are approximate. Because of its diversity and flexibility as an analysis tool, it is receiving much attention 

in engineering. The fast improvements in computer hardware technology and slashing of cost of 

computers have boosted this method, since the computer is the basic need for the application of this 

method. A number of popular brand of finite element analysis packages are now available 

commercially. Some of the popular packages are ETABS, SAP2000, ABAQUS, STAAD-PRO, GT-

STRUDEL, NASTRAN, NISA and ANSYS. Using these packages one can analyse several complex 

structures. 

 

The finite element analysis originated as a method of stress analysis in the design of aircrafts. It started 

as an extension of matrix method of structural analysis. Today this method is used not only for the 

analysis in solid mechanics, but even in the analysis of fluid flow, heat transfer, electric and magnetic 

fields and many others. Civil engineers use this method extensively for the analysis of beams, space 

frames, plates, shells, folded plates, foundations, rock mechanics problems and seepage analysis of fluid 

through porous media. Both static and dynamic problems can be handled by finite element analysis. 

This method is used extensively for the analysis and design of ships, aircrafts, space crafts, electric 

motors and heat engines. 

 

General Description of the Method 

In engineering problems there are some basic unknowns. If they are found, the behaviour of the entire 

structure can be predicted. The basic unknowns or the Field variables which are encountered in the 

engineering problems are displacements in solid mechanics, velocities in fluid mechanics, electric and 

magnetic potentials in electrical engineering and temperatures in heat flow problems. In a continuum, 

these unknowns are infinite. The finite element procedure reduces such unknowns to a finite number 

by dividing the solution region into small parts called elements and by expressing the unknown field 

variables in terms of assumed approximating functions (Interpolating functions/Shape functions) 

within each element. The approximating functions are defined in terms of field variables of specified 

points called nodes or nodal points. Thus in the finite element analysis the unknowns are the field 

variables of the nodal points. Once these are found the field variables at any point can be found by using 

interpolation functions. After selecting elements and nodal unknowns next step in finite element 

analysis is to assemble element properties for each element. For example, in solid mechanics, we have 

to find the force-displacement i.e. stiffness characteristics of each individual element.  

 

Mathematically this relationship is of the form 

[k]e {δ}e = {F}e  

Here [k]e is element stiffness matrix, {δ }e is nodal displacement vector of the element and {F}e is nodal 

force vector. The element of stiffness matrix kij represent the force in coordinate direction ‘i’ due to a 

unit displacement in coordinate direction ‘j’. Four methods are available for formulating these element 

propertiesviz. direct approach, variational approach, weighted residual approach and energy balance 

approach. Any one of these methods can be used for assembling element properties. In solid mechanics 

variational approach is commonly employed to assemble stiffness matrix and nodal force vector 

(consistant loads). 
 

Element properties are used to assemble global properties/structure properties to get system equations 

[k] {δ } = {F}. Then the boundary conditions are imposed. The solution of these simultaneous equations 
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give the nodal unknowns. Using these nodal values additional calculations are made to get the required 

values e.g. stresses, strains, moments, etc. in solid mechanics problems. 

 

Thus the various steps involved in the finite element analysis are: 

(i) Select suitable field variables and the elements. 

(ii) Discretize the continua. 

(iii) Select interpolation functions. 

(iv) Find the element properties. 

(v) Assemble element properties to get global properties. 

(vi) Impose the boundary conditions. 

(vii) Solve the system equations to get the nodal unknowns. 

(viii) Make the additional calculations to get the required values. 
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A Brief Explanation of a Stress Analysis Problem 
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Courtesy: S.S. Bhavikatti 
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Need for Studying FEM 

Now, a number of users friendly packages are available in the market. Hence one may ask the 

question ‘What is the need to study FEA?’. 

 

The above argument is not sound. The finite element knowledge makes a good engineer better while 

just user without the knowledge of FEA may produce more dangerous results. To use the FEA 

packages properly, the user must know the following points clearly: 

 

1. Which elements are to be used for solving the problem in hand. 

2. How to discretize to get good results. 

3. How to introduce boundary conditions properly. 

4. How the element properties are developed and what are their limitations. 

5. How the displays are developed in pre and post processor to understand their limitations. 

6. To understand the difficulties involved in the development of FEA programs and hence the need for 

checking the commercially available packages with the results of standard cases. 

 

Unless user has the background of FEA, he may produce worst results and may go with 

overconfidence. Hence it is necessary that the users of FEA package should have sound knowledge of 

FEA. 
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FEA Software in General and ETABS  

Most of the commonly available Finite Element Analysis (FEA) softwares have two main 

features: 

 Graphical User Interface (GUI) 

 Programming Interface 

Some softwares come with both of the features available while some only have the GUI. In 

GUI, users interact with the computer through different windows, icons and menus and which 

can be manipulated by a mouse. The programming interface requires users to code to interact 

with the computer and requires a certain degree of expertise in the programming language.   

ETABS is a popular FEA software among Civil Engineers with main focus on Graphical 

User Interface. ETABS stands for Extended Three Dimensional Analysis of Building 

Structure. 

As it can be used without the requirement to code, it can be easily used by users who are not 

familiar with coding. ETABS is suitable for analysis and designing multi-storied buildings 

and its different parts such as beams, columns, slabs and so on. The user interface is self-

explanatory and the help file provided along with the software guides users along the way. 

For these reasons, it is very user friendly and  it is being used by Civil Engineers throughout 

the world. 

In this course, ETABS version 9.6.2 will be used and all the following sections will be 

described in accordance with this version. 
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Introduction to ETABS’s User Interface 

 

 Main Title Bar 

 Menu Bar 

 Toolbar 

 Display Title Bar 

 

 

 

Figure 1: ETABS user interface 
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Methodology of Finite Element Software  

Finite element software generally follows three steps as given below- 

1. Preprocessing: Object based model generation 

 Define materials   

 Define geometry  

 Define elements  

 Draw ( line, area etc)  

 Mesh (convert object based model to element based model)  

 Merge points  

 Load application 

2. Processing: Analysis / Solution 

 Static Analysis 

 Dynamic Analysis 

3. Post processing 

 Result interpretation ( SFD, BMD, Displacement, Stress etc) 

 Design 

 

Basic Workflow  

 

The following provides a broad overview of the basic modeling, analysis, and design 

processes:  

 

1. Open a file.  9. Assign loads. 

2. Set the units. 10. Edit the model geometry if necessary. 

3. Set up grid lines. 11. View the model. 

4. Define story levels. 12. Analyze the model. 

5. Define material and member properties. 13. Display results for checking. 

6. Draw structural objects. 14. Design the model. 

7. Assign supports. 15. Generate output. 

8. Define load cases 16. Save the model 
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New Model Initialization 

 

 

Figure 2: Grid Seleciton 

     

 File >New model 

 If it is uniform grid then fill up the “Uniform Grid Spacing” box  

 Input number of grid in X,Y direction 

 Take number of stories 

 Change unit to kip-ft 

 Input typical story height 

 Input bottom story height 

 If the grid is not uniform then go to the “Custom Grid Spacing” 

 Edit grid 

 Check spacing 

 Check glue to grid lines 

 Input spacing of grid in X,Y direction 

 ok 
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Define Material Properties and Frame Section 

 

 Material properties 

 Concrete  

 Modify if need 

 

 Frame section 

 Select all existing property 

 Delete all 

 Add rectangular/circle 

 For Beam 

 Select reinforcement 

 Then select beam 

 Define all frame section in this process 

 

 

 
 

 
Figure 3: Material Property Initialization   
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Beam Modeling 

 

 Model the following beam and find the SFD and BMD. 

 

Figure 4: Beam Model 

1. File menu > New Model  

2. Use Number of Grid Lines edit box. Specify the number of grid lines along X and Y 

direction. 

3. Define materials and beam section 

4. Draw lines as shown in figure by clicking Draw Lines icon from Draw toolbar 

5. Select the desired point to assign support 

6. Click the Assign menu > Joint/Point > Restraints (Supports) 

7. Select the desired point to assign load 

8. Assign menu > Joint/Point load   

9. Select the desired beam to assign load 

10. Assign menu > frame/ Line load   

11. Analysis > Run Analysis. 

12. Go options tab and uncheck moment diagram on tension side 

13. To show support reaction, shear force/Bending moment click Show Member 

Forces/Stress Diagram 

 

 

 

6 ft

4.4 k/ft

  

10 ft 12 ft

10 K
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Frame Modeling 

 Model the following frame and find out bending moment, shear force and 

reactions. 

 

 

Figure 5: Frame Model  

To analyze this frame need to complete the following steps: 

1. Click New icon from main toolbar  

2. Chose Default.edb from new model initialization window  

3. Modify data from Building Plan Grid System and Story Data Definition window as 

mentioned below 

 Grid Dimension window 

1. No of lines in x direction = 3 

2. No of lines in y direction = 1 

 Units = kip-ft 

 Story Dimension  

1. No of story = 1 

2. Bottom Story height = 4 ft 

 Click on Edit grid from Custom grid spacing and modify grid data 

from Define Grid Data window as required 

 Click Ok 

5 ft

 

 

10 k

8 ft

10 ft

4 ft
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4. Click Edit → Edit Story Data → Insert Story and change Story height = 10 ft from 

Insert New Story window. 

5. Click Set Elevation View icon form main toolbar and select elevation view 

6. Draw lines as shown in figure by clicking Draw Lines icon from Draw toolbar 

7. Selects the points respectively where supports to be create and select Assign → 

Joint/Point → Restrains/Supports and select the support condition. 

8. Select the point where point load to be create and select Assign → Joint/Point Loads 

→ Forces and modify loads from Point Forces window. 

9. Finally click on Run Analysis icon from Main toolbar. 

10. To show deflected shape Show Deformed Shape icon from Display window.  

11. To show shear force/Bending moment click Show Member Forces/Stress Diagram 

→ Frame/Pier/Spandrel Forces from Display toolbar.  

 Select Component from Member Force Diagram for Frames window 

1. Moment → Moment  3-3 

2. Shear → Shear 2-2 

 To show the value select Show values on Diagram on same window 

 To show the local axes of forces select Object Fill & Line Local Axes from 

Set Building View Option window. 
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Slab Modeling 

 

      Define slab 

         

 Add new slab 

 Material: concrete 

 Thickness:  

 membrane: 5” , Bending: 5” [for example]      

 Type: shell 

 Ok 

A wall or slab section (element) can have shell, membrane or plate-type behavior.  

 Shell-type behavior means that both in-plane membrane stiffness and out-of-plane plate 

bending stiffness are provided for the section.  

 Membrane-type behavior means that only in-plane membrane stiffness is provided for 

the section.  

 Plate-type behavior means that only out-of-plane plate bending stiffness is provided 

for the section.  

 

Figure 6: Shell Element – subjected to both in plane and out of plane forces (Courtesy: 

DIANA FEA Version 10.1 Software Manual) 
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Figure 7: Bending Plate Element on the Left and Membrane Element on the Right 

(Courtesy: DIANA FEA Version 10.1 Software Manual) 

 

When a section has plate-type or shell-type behavior, use the Thick Plate check box to 

include or not include thick plate behavior. When thick plate behavior is included (the 

check box is checked), out-of-plane shearing deformations are considered in the analysis. 

When thick plate behavior is not included (the check box is unchecked), these shearing 

deformations are not considered in the analysis. We recommend that you typically do not 

use the thick plate option in ETABS, except when modeling thick footings or mat 

foundations. 

 

Mesh: 

1. Manual Mesh: Click the Edit > Mesh Area 

2. Auto Mesh: Click the Assign menu > Shell/Area > Area Object Mesh Options 

command to access the Area Object Auto Mesh Options form. 

Mesh Optimization: 

In FEA, higher numbers of meshes (more number of elements) result in a more accurate 

analysis while increasing the computer memory requirement. Thus, it is of the highest 

priority to achieve a trade-off between numbers of meshes and memory requirement. In, 

analysis of complex structures requiring high degree of precision, higher number of 

meshes should be employed while in ordinary and less complex structures, relatively 

lower number of meshes should be used.     
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Figure 8: Graph showing Error Percentage vs. Number of Elements used in FEA (S.S. 

Bhavikatti) 

 

 

 Model the following slab as one way and find Mmax and Mmin. 

 

Figure 9: Slab Model - 1 
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1. Open the ETABS Window 

2. Click New icon from main toolbar 

3. Chose Default.edb from new model initialization window  

4. Modify data from Building Plan Grid System and Story Data Definition window as 

mentioned below 

 Grid Dimension window 

a) No of lines in x direction = 2 

b) No of lines in y direction = 2 

c) Units = kip-ft 

d) Story Dimension  

No of story = 1 

Bottom Story height = 4 ft 

e) Click on Edit grid from Custom grid spacing and modify 

grid data from Define Grid Data window as required 

5. Click Define Wall/Slab/Deck Section icon to define the slab. Then modify the data 

from the Define Wall/Slab/Deck Section window as mentioned below: 

a. Delete sections 

b. Select Add New Slab from Click to option. 

c. Modify in Wall/Slab Section window 

i. Section Name→ Slab  

ii. Material→ CONC 

iii. Membrane → 5” 

iv. Bending → 5” 

v. Type→ Shell 

Click the Draw Area icon from Draw toolbar and draw the area on grid as figure in 

clockwise direction. 

6. Select the drawn slab by clicking Select Objects icon from Draw toolbar 

7. Click Edit → Mesh Areas and modify the Mesh Selected Area window as shown 

below: 

i. Mesh Quads/Triangles into → 4 x 4 [along X and Y direction 

respectively] 
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8. Selects the boundary of the slab respectively where supports to be create and select 

Assign → Joint/Point → Restraints/Supports and select the support condition. 

9. Click on Select → by Wall/Slab/Deck Section → Select (Slab) Ok to select the slab 

where load to be create and select Assign → Shell/Area Loads → Uniform and modify 

loads from Uniform Surface Loads (70psf) window. 

10. Finally click on Run Analysis icon from Main toolbar. 

11. To show deflected shape select the 3D View window & click Show Deformed Shape 

icon from Display window.  

12. To show Bending moment click Show Member Forces/Stress Diagram → Shell 

Stresses/Forces from Display toolbar.  

 Select Component from Element Force/Stress Contours For Shells  

window 

13. Component → M 11/ M 22 

 To show the local axes of forces select Object Fill & Area Local Axes from 

Set Building View Option window. 

 

 

14. To get moment in one direction as it is a one way slab following steps needed to be 

performed. 

 Define Wall/Slab/Deck Section > Modify 

>Set modifiers (m2-2 = 0) 

 

 

 Model a simply supported 10 x 10 ft, two way slab (5” thickness) and analyze. 

LL=100 psf and use manual mashing. 

 

1. Click Define Wall/Slab/Deck Section icon to define the slab. Then modify the data 

from the Define Wall/Slab/Deck Section window as mentioned below: 

Moment M maximum  (Ib-in) M minimum (Ib-in) 

M 1-1 330.003 0.773 

M 2-2 64.584 12.346 

Moment M maximum  (Ib-in) M minimum (Ib-in) 

M 1-1 315.00 0.00 

M 2-2 0.990 0.990 
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a. Delete sections 

b. Select Add New Slab from Click to option. 

c. Modify in Wall/Slab Section window 

i. Section Name → Slab  

ii. Material → CONC 

iii. Membrane → 5” 

iv. Bending → 5” 

v. Type→ Shell 

Click the Draw Area icon from Draw toolbar and draw the area on grid as figure in 

clockwise direction. 

2. Select the drawn slab by clicking Select Objects icon from Draw toolbar 

3. Click Edit → Mesh Areas and modify the Mesh Selected Area window as shown 

below: 

ii. Mesh Quads/Triangles into → 10 x 10 [along X and Y direction 

respectively] 

4. Selects the boundary of the slab respectively where supports to be create and select 

Assign → Joint/Point → Restraints/Supports and select the support condition. 

5. Click on Select → by Wall/Slab/Deck Section → Select (Slab) Ok to select the slab 

where load to be create and select Assign → Shell/Area Loads → Uniform and modify 

loads from Uniform Surface Loads window. 

6. Finally click on Run Analysis icon from Main toolbar. 

7. To show deflected shape select the 3D View window & click Show Deformed Shape 

icon from Display window.  

8. To show Bending moment click Show Member Forces/Stress Diagram → Shell 

Stresses/Forces from Display toolbar.  

 Select Component from Element Force/Stress Contours For Shells  

window 

9. Component → M 11/ M 22 

 To show the local axes of forces select Object Fill &Area Local Axes from 

Set Building View Option window. 
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 Model the following slab and find the following items. 

 

a) Find the –ve moment of the one way slab 

b) Reduce the moment capacity of the slab and find the +M of the beam. 

c) Define the slab as a member and then as a shell, find out the difference. 

Given that, 

Slab thickness = 6 in. 

Beam = 10 X 24 in. 

LL = 100 psf 

Note: Apply restrain against the rotation of the supports about X axis. 

 

 

 

 

 

 

  

 

 

  

 

Figure 10: Slab Model - 2 

 

 

Slab as a shell:  

Maximum bending moment 6.86 k-ft 

Slab as a membrane:  

Maximum bending moment 7.68 k-ft 

3 ft 

3 ft 

10 ft 
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Figure 11: Slab Model – 2 loading 

Check: 

UDL on beam = (100 X 10 X 6) / 10 = 600 Ib/ft 

  = 0.6 k/ft 

Maximum moment= wl2/8 

 = (0.6 X 102) /8 

            = 7.5 k-ft 

 

 

 

10 ft 

100 psf = 0.6 k/ft 
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Modeling and Analysis of a Building 

3RD F, 4RT F
GF, 1ST F, 2ND F

GB2/B3GB2/B3

GB1/B1

GB1/B1

GB2/B2

C2C2

C2

C2 C1

C1C1

C1

C3

12'

15'

16'16'18'

 

16'18'

Fifh Floor (Roof)

Forth Floor

Third Floor

Second Floor

First Floor

Ground Floor

10'

10'

10'

10'

10'

6'

 

 

Required definition, chart / data for modeling (According to BNBC article 2.5.5) 

Sections 

C1= 10X10 in.  C2 = 10X15 in.  C3= 12X15 in. 

B1= 10X16 in.    B2 = 10X18 in.  B3= 10X12 in. 

GB1= 10X16 in. GB2= 10X14 in. 

Slab thickness= 5 in.  

Loads 

DL= 120 psf LL= 50 psf Zone =2 

Material properties 

𝑓𝑐
′ = 4 𝑘𝑠𝑖 = 4000 𝑝𝑠𝑖 𝑓𝑦 = 60 𝑘𝑠𝑖 

𝐸 =  57000√𝑓𝑐′  (𝑝𝑠𝑖) 

 

Figure 12: Concrete and Steel Stress-strain Diagram 

(Courtesy: University of Colorado Boulder) 

 

fy 

fc’ 
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Sustained Wind Pressure  

The sustained wind pressure, qz on a building surface at any height z above ground shall be 

calculated from the following relation: 

qz = Cc C1Cz Vb
2 

Where, qz = sustained wind pressure at height z, KN/m2 

 C1 = structure importance coefficient as given in Table 6.2.9  

Cc - velocity-to-pressure conversion coefficient = 47.2 x10-6 

Cz = combined height and exposure coefficient as given in Table 6.2.10  

Vb = basic wind speed in km/h obtained front Sec 2.4.5 

 

Seismic Dead Load 

Seismic dead load, W, is the total dead load of a building or a structure, including permanent 

partitions, and applicable portions of other loads listed below : 

 a) In storage and warehouse occupancies, a minimum of 25 per cent of the floor live load shall 

be applicable.  

b) Where an allowance for partition load is included in the floor design in accordance with Sec 

2.3.3.3, all such loads but not less than 0.6 KN/m2 shall be applicable. 

 c) Total weight of permanent equipment shall be included. 

 

Method A for time period calculation 

For all buildings the value of T may be approximated by the following formula: 

T = Ct (hn) 3/4 

Where, Ct = 0.083 for steel moment resisting frames  

                 = 0.073 for reinforced concrete moment resisting frames, and eccentric braced steel 

frames  

                 = 0.049 for all other structural systems  

              hn = Height in metres above the base to level n. 
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Table  6.2.24 : Response Modification Coefficient for Structural Systems, R (BNBC- 1993) 

Basic Structural  System(1) Description of Lateral Force Resisting System      R 

a.   Bearing Wall 
       System 

1. Light framed walls with shear panels 
  i)   Plywood walls for structures, 3 storeys or less 
 ii)   All other light framed walls 
2.  Shear walls 
 i) Concrete 
      ii)   Masonry 
3.  Light steel framed bearing walls with tension only bracing 
4.  Braced frames where bracing carries gravity loads 
 i)   Steel 
   ii)   Concrete (3) 
    iii)   Heavy  timber 

8 
6 
6 
6 
4 
6 
4 
4 

b. Building      

        Frame 
        System 

1.  Steel eccentric braced frame (EBF) 
2.  Light framed walls with shear panels 
      i)   Plywood walls for structures 3-storeys or less 
     ii)   All other light framed walls 
3.  Shear walls 
      i)   Concrete 
     ii)   Masonry 
4.  Concentric braced frames (CBF) 
      i)   Steel 
     ii)  Concrete (3) 
    iii)   Heavy timber 

10 
9 
7 
8 
8 
8 
8 
8 

c.   Moment Resisting 

Frame System 
1.  Special moment resisting frames (SMRF) 
 i)  Steel 
     ii)  Concrete 
2.  Intermediate moment resisting frames (IMRF), concrete(4) 
3.  Ordinary moment resisting  frames (OMRF)  
      i)   Steel 
     ii)   Concrete (5) 

12 
12 
8 
6 
5 

d.  Dual System 1.  Shear walls 

       i)  Concrete with steel or concrete SMRF 

      ii)  Concrete with steel OMRF 

     iii)  Concrete with concrete IMRF (4) 

     iv)  Masonry with steel or concrete  SMRF 

 v)  Masonry with steel OMRF 

    vi) Masonry with concrete IMRF (3) 

2.  Steel EBF  

     i) With steel SMRF 

     ii) With steel OMRF 

3.  Concentric braced frame (CBF) 

     i) Steel with steel SMRF 

     ii)   Steel with steel OMRF 

    iii) Concrete with concrete SMRF (3) 

     iv) Concrete with concrete IMRF (3) 

12 

6 

9 

8 

6 

7 

12 

6 

10 

6 

9 

6 

e.  Special Structural  

     Systems 

          See Sec 1.3.2, 1.3.3, 1.3.5  

Notes : (1) Basic Structural Systems are defined in Sec 1.3.2, Chapter 1. 

             (2) See Sec 2.5.6.6 for combination of structural systems, and Sec 1.3.5 for system limitations. 

             (3) Prohibited in Seismic Zone 3. 

             (4) Prohibited in Seismic Zone 3 except as permitted in Sec 2.5.9.3. 

             (5) Prohibited in Seismic Zones 2 and 3. Sec 1.7.2.6. 
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Table  6.2.25 : Site Coefficient, S (BNBC- 1993) 

 

Table  6.2.22 : Seismic Zone Coefficient, Z (BNBC- 1993) 
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To solve this structure need to complete the following steps: 

1. Open the ETABS Window 

2. Click New icon from main toolbar 

3. Chose Default.edb from new model initialization window  

4. Modify data from Building Plan Grid System and Story Data Definition window as 

mentioned below 

 Grid Dimension window 

1. No of lines in x direction = 3 

2. No of lines in y direction = 3 

 Units = kip-ft 

 Story Dimension  

1. No of story = 1 

2. Bottom Story height = 6 ft 

 Click on Edit grid from Custom grid spacing and modify grid data from 

Define Grid Data window as required 

 Click Ok 

5. Click Define Frame Section icon to define the Columns. Then 

modify the data from the  Define Frame Section Properties 

window as mentioned below: 

a. Delete sections 

b. Select Add Rectangular from Click to option then Ok. 

c. Modify in Rectangular Section window 

i.Section Name→ C1  

ii.Material→ CONC 

iii.Depth → 10” 

iv.Width → 10”            

d. Then click Ok. Similarly define C2 & C3. 

6. Click Define Frame Section icon to define the Beams. Then modify 

the data from the  Define Frame Section Properties window as 

mentioned below: 

a. Delete sections 
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b. Select Add Rectangular from Click to option then Ok. 

c. Modify in Rectangular Section window 

i.Section Name→ GB1 

ii.Material→ CONC 

iii.Depth → 16” 

iv.Width → 10” 

v.Reinforcement → Design Type → Beam 

d. Then click Ok. Similarly define GB2, B1, B2 and B3. 

5. Click Set Plan View icon form main toolbar and select Plan view. 

6. Define load cases by Clicking Define Static Load Case icon from define toolbar and 

define the load cases as Code. 

 

 

Figure 13: Load Cases 

7. Draw Grade Beams as shows in figure by clicking Draw Lines icon from Draw toolbar 

& Selecting GB1 & GB2 respectively. 

8. Place the column by clicking Create Columns in Region or at Clicks icon from Draw 

toolbar & place the columns respectively as shown in figure. 

9. Click Edit → Edit Story Data → Insert Story and change Story height = 10 ft from 

Insert New Story window. 

10. Delete the beams from plan view. 

11. Draw Beams as shows in figure by clicking Draw Lines icon from Draw toolbar & 

Selecting B1, B2 & B3 respectively.  

12. Click Define Wall/Slab/Deck Section icon to define the slab. Then modify the data from 

the  Define Wall/Slab/Deck Section window as mentioned below: 
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e. Delete sections 

f. Select Add New Slab from Click to option. 

g. Modify in Wall/Slab Section window 

i. Section Name→ Slab  

ii. Material→ CONC 

iii. Membrane → 5” 

iv. Bending → 5” 

v. Type → Shell 

vi. Set modifier → modify the moment value nearly zero. 

13. Click the Draw Area icon from Draw toolbar and draw the area on grid as figure in 

clockwise direction. 

14. Select the drawn slab by clicking Select Objects icon from Draw toolbar. 

15. Click Define → Mass Sources → From Loads and select the loads which are 

considered for mash & remove the selection of Include Lateral Mass Only & Lump 

Lateral Mass at Story Levels options. 

16. Select the slabs & click Assign → Shell Area → Area Object Mesh Option → Auto 

Mesh object into Structural Elements. Then select the third & fourth option and define 

maximum element size 2.  

17. To show the mesh effects on slab select Object Fill, Auto Area Mesh & Apply to All 

Window from Set Building View Option window. 

18. Select One Storey from Status Bar.  

19. Selects the Columns at base where supports to be create and select Assign → 

Joint/Point → Restrains/Supports and select the support condition. 

20. Click on Select → by Wall/Slab/Deck Section → Select (Slab) Okto select the slab 

where load to be create and select Assign → Shell/Area Loads → Uniform and modify 

loads respectively from Uniform Surface Loads window. 

21. Click Special Seismic Load Effects→ Do Not Include Special Seismic Design Data 

→ Ok. 

22. Click Edit → Edit Story Data → Insert Story and change Story height = 10 ft and No 

of Stories = 2 from Insert New Story window. 

23. To modify the story name click Edit → Edit Story Data → Edit Story Data and change 

the name of the floor as required. 

24. Delete the unnecessary structural member from fourth & fifth floor. 
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25.  Modify lateral loads by Clicking Define Static Load Case icon from define toolbar and 

put the reference value as follows. 

26. Select EQX and Click Modify lateral load and put the values as below. 

 

 Earth quake in X Direction 

 Direction & Eccentricity – X Dir 

 Ct =0.03 for RCC building [for height in ft] for Method A 

 Rw= 8 

 Z = 0.15 

 S = 1.5 

 I =1 

       Similarly modify Earth quake in Y Direction 

 

Figure 14: Wind Load Initialization  
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27. Finally click on Run Analysis icon from Main toolbar. 

28. To Check the error in data input for lateral load click Display → Show table and select 

the items and check the earth quake load in X in Y direction. If the values are equal the 

inputted data is ok, else there is an error. Find the error and modify data.  

29. To show deflected shape select the 3D View window & click Show Deformed Shape 

icon from Display window.  

30. To show Bending moment click Show Member Forces/Stress Diagram → Shell 

Stresses/Forces from Display toolbar.  

 Select Component from Element Force/Stress Contours For Shells  

window 

 Component → M 11/ M 22 

 To show the local axes of forces select Object Fill & Area Local Axes from 

Set Building View Option window. 

 

Checks for model 

 

 For Earthquake load 

 

1. ∑EQX = ∑EQY. 

2. (V/W) = (ZIC/R). [Allow max 5% variation] 

 

 For Wind load 

 

3. Maximum deflection ≤ H/480, H=Height of structure from GF. 

4. Drift ratio, ∆/h ≤ {0.005 if T< 0.7 sec  

                                        {0.004 if T≥ 0.7 sec 

            Where, ∆ = Displacement of one level relative to below level.   

                         h =storey height. 
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Design of a Building 

 Calculate 

the gravity loads, 

model, analyze and 

hence design the 

following 

building.  

Figure 15: Buidling Plan 

 

 

Load calculation 

1. Load from partition wall 

Considering, all exterior and 

interior brick walls are 5 

inch and brick wall through 

all beam line.  

Load on beam line 

 

Load of wall on beam line =  
5×10×120 

12
 = 500 lb/ft= 0.5 k/ft 

Commands 

i. Select the perimeter 

beam along grid line 

between grid 

lines by left clicking on 

it once in Plan View.  

Note that the 

selected lines appear 

dashed.  

ii. Select the other 

perimeter 

beams in a similar 
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manner. When you have selected all perimeter beams, the status bar should indicate. 

iii. Click the Assign > Frame/Line Loads > Distributed command or click the Assign 

Frame Distributed Load button. Select PW Load Case Name drop-down list.  

iv. Set the units drop-down list in the form to lb-ft and then enter load in the Load edit 

box that is located in the Uniform Load area of the form.  

v. Click the OK button on the Frame Distributed Loads form to accept the uniform 

superimposed dead load that is applied to the perimeter beams. 

vi. Click the File menu > Save command, or the Save button, to save your model. 

 

Load on slab from wall 

 

Panel AB46, from 9 ft wall = 
9×(

5

12
)×10×120

16×12
  = 23.43 psf 

From similar calculation, 

On panel BC46= (9.06 + 9.06) psf  

Panel BC14=18.11 psf 

According to BNBC, article 2.3.6 minimum partition wall load on slab = 25 psf. 

Commands  

i. In this Step, the superimposed dead and live gravity loads will be applied to the model. 

Make sure that the Similar Stories feature is enabled and that the Plan View is active. 

ii. Click anywhere on the slab (but not on a beam) to select. A dashed line should appear 

around the perimeter of the slab. This dashed line indicates that the slab has been 

selected. If you make a mistake in selecting, click the Clear Selection button , and try 

again. 

iii. Click the Assign > Shell/Area Loads > Uniform command or click the Assign Uniform 

Load button. This displays the Uniform Surface Loads form. Select SDEAD from the 

Load Case Name drop-down list, as shown in Figure 29.  

iv. Select lb-ft from the drop down list in the Calculator form and then type load in the 

Formula edit box. Be sure to set the units before typing.  

v. Click the OK button on the Uniform Surface Loads form to accept the superimposed 

dead load.  

 

2. Load from Lift 

Load of the lift core can be taken by the enclosing beam or slab provided on the shear wall. 

Let us consider 10 persons with 80 kg each. 
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W=10× 80 = 800 𝑘𝑔 =
800×2.204

1000
 = 1.76 𝑘𝑖𝑝 

For 8ft by 8ft lift core, 

Assuming self-weight of lift= 5 𝑘𝑖𝑝 

Total load from lift =5+1.76 =6.76 𝑘𝑖𝑝 

i. Load on lift slab: 

Area of lift slab = 8 𝑓𝑡 × 8 𝑓𝑡 = 64 𝑠𝑞𝑓𝑡 

Load on slab =
6.76

64
 =0.11 𝑘𝑠𝑓 

ii. Load on enclosing beam : 

Perimeter of the lift core= 2(8 + 8) = 32 𝑓𝑡 

On beam =
6.76

32
= 0.21 𝑘 𝑝𝑒𝑟 𝑓𝑡 

 

 

 

 

 

 

3. Load of Water Tank 

 

According to BNBC, Q= 210 lpcd 

 P   = total No of persons 

      = No of storey X unit per floor X Avg no of person in one family 

      = 5x2x6 = 60 

Q= 210 x 60=12600 litre/day 

Let us consider pumping twice a day 

Q = 12600 x 0.5= 6300 litre 

Volume of tank =6300/1000 =6.3 m3=6.3 x (3.28)3 =222.31 ft3  

Height of wall of tank = V/A = 222.31/ (8x12.5) =2.22 ft < 3 ft (min) 

h= 3 ft. 
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Load application pattern  

UDL from the top slab and the enclosing wall                               on beam 

Water load                                       on bottom slab 

i. Water load = 3 x 62.5 =  187.5 psf  ( should be given on bottom slab ) 

ii. Let the thickness of the wall is 8 inch 

Wall load= 
8×3×150

12
 = 300 = 0.3 k/ft (should be given on bottom beam) 

Let the tank top slab = 4 in 

Slab weight = 
8×12.5×4×150

12
 = 5000 lb = 5kip 

Considering, weight of slab will be taken by beam. 

UDL on beam (fromslab) = load / perimeter of slab 

Perimeter = 2 (8+12.5) = 41 ft 

UDL= 5/41=0.12 k/ft(should be given on bottom beam) 

Total UDL on beam = 0.3+ 0.12= 0.42 k/ft 

 

Bottom slab thickness = 
Perimeter 

180
 =  

41×12

180
 =2.73 inch ≅ 3 𝑖𝑛𝑐ℎ 

 

4. Load from Stair 

Dead load 

Weight of steps = 9x 
1

2
  x 

6×10

144
 x 

150

7.5
  = 37.5 lb/ft               

Waist slab= 9 .01 x 
6

12
  x 1 x 

150

7.5
  =90.1 lb/ft 

Landing slab =
6

12
  x 1x 150= 75 lb/ft 

 75 lb/ft 127.6 lb/ ft 

 

                          A                                                               B 

  5 ft 7.5 ft 

Landing beam  stair beam 

Figure 16: Stair Loading 
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RB = 
(937.5+8373.75)

12.5
 = 744.9 lb = 0.75 k  

RA = [5x0.075+0.1276X7.5] - 0.75 = 0.582 k 

Live load 

Similarly 100 psf live load distributed on one flight of 12.5 ft gives reactions of 0.63 kip per 

ft on both the stair beams. 

 

Modeling and Design 

Model and analyze the building as previous  

Design Steps for a Typical Building 

 Unlock model. 

 Option > Preference > Concrete frame design > Design code > ACI 318-99. 

 Define >Add default design combos > Concrete frame design > Convert to user 

defined.   

Or 

 Define > Load combinations  

 

Name Details Type 

COMB1. 1.4DL +1.7 LL 

ADD 

COMB2. 1.05DL+1.275LL+1.275WX 

COMB3. 1.05DL+1.275LL-1.275WX 

COMB4. 1.05DL+1.275LL+1.275WY 

COMB5. 1.05DL+1.275LL-1.275WY 

COMB6. 1.05DL+1.275LL+1.405EQX 

COMB7. 1.05DL+1.275LL-1.405EQX 

COMB8. 1.05DL+1.275LL+1.405EQY 

COMB9. 1.05DL+1.275LL-1.405EQY 

Service. DL+LL 

Envelope. COMB1. + COMB2. + ….. + COMB9. ENV 
 

Figure 17: Table of Load Combinations 

 Select all (Ctrl A) > Design> Concrete frame design > View/ Revise over view> 

Element type > Sway intermediate. 

 Run model. 

 Design > Concrete frame design > Select design combos > Envelope. 

 Design > Concrete frame design > Start design. 
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Design Output Utilization 

Beam 

 Observe colour (DCR) of beams and steel area.  

 If  failure  occurs (red in colour) then sections should be changed 

 

Column 

 Design > Concrete frame design > Display design info > Rebar percentage. 

 Observe colour (DCR) of the column & steel area percentage. 

 

Footing 

 Observe Service load combination column reactions for footing size determination. 

 

Slab 

 ETABS cannot design slab (Use SAFE or Do manual design). 

 We can only take the moment from the contour 

 

 
Figure 18: Output colour of different Demand Capacity Ratio (DCR)  for Steel in ETABS 

Shear Wall Modeling 

 

Lateral Load Resisting System of Building 
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• Lateral loads on buildings are induced by wind, earthquake, and soil pressure 

• Lateral loads increase as a structural design issue as buildings become taller 

• Systems for resisting lateral loads include: 

– Bracing (diagonal, X, K, knee, etc.)  

– Shear walls (reinforced concrete or masonry) 

– Rigid connections (reinforced concrete, steel) 

– Combinations of these three (common) 

 

 

Figure 19: Basic Types of Shear Walls 

 

Lateral load resistance: shear walls 

Shear walls:  

  Usually reinforced concrete or masonry 

   Located in exterior and/or interior bays 

  Not necessarily in same location at all levels 

  Often double as elevator shaft and/or stairwell 

enclosures 

  Those shown for N-S resistance only 

 Floor diaphragms integral part of the lateral load 

resisting system. 

  

 

Some Modeling Considerations for Walls using Shell Elements 

 Multiple elements facilitate greater accuracy in determination of stress distribution 

and allow easy modeling of openings 

Figure 20: Shear Wall 3D View 
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 Figure 21: Shear Wall Consideration 

 

 

 

 

 

 

 In general the mesh in the slab should match with mesh in the wall to establish 

connection. To avoid connection problem use merge point command from  

Edit> Marge points. 
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Concrete shear wall design 

 2D wall pier design and boundary-member checks 

 2D wall spandrel design 

 3D wall pier check for provided reinforcement 

 Graphical Section Designer for concrete rebar location 

 Graphical display of reinforcement and stress ratios 

 Interactive design and review 

 Summary and detailed reports including database formats 

 

Slab 
 Wall 

Connection 

Figure 22: Shear Wall Connection 



Department of Civil Engineering 
AUST 

 

 

CE 418: Computer Aided Analysis and Design Page 41 
 

 

Figure 23: Shear Wall Side View 

COMMANDS 

1. While modeling, define Shear Wall elements  

2. Assign pier and spandrel label 

3. Choose the Shear Wall design code and  review other related preferences and 

revise them if necessary  
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Design of Water Tank 
Storage reservoirs and overhead tank are used to store water, liquid petroleum, petroleum products and 

similar liquids. All tanks are designed as crack free structures to eliminate any leakage. Water or raw 

petroleum retaining slab and walls can be of reinforced concrete with adequate cover to the 

reinforcement. Water and petroleum and react with concrete and, therefore, no special treatment to the 

surface is required. Industrial wastes can also be collected and processed in concrete tanks with few 

exceptions. The petroleum product such as petrol, diesel oil, etc. are likely to leak through the concrete 

walls, therefore such tanks need special membranes to prevent leakage. Reservoir is a common term 

applied to liquid storage structure and it can be below or above the ground level. Reservoirs below the 

ground level are normally built to store large quantities of water whereas those of overhead type are 

built for direct distribution by gravity flow and are usually of smaller capacity. 

Objective 

 To make a study about the analysis and design of water tanks. 

 To make a study about the guidelines for the design of liquid retaining structure according to 

Code requirements. 

 To know about the design philosophy for the safe and economical design of water tank. 

 Solve water tank related problems using Software (SAP) to avoid the tedious calculations. 

 Hence, check the validity of the result with hand calculation. 

Types of Water Tank 

 

 

Water Tank

Based on the 
placement of tank

Resting on 
Ground

Flexible or Free 
Base

Hinged

FixedUnderground

Elevated

Based on the 
shape of the tank

Circular

Rectangular

Spherical

Intze

Conical Bottom
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Figure 24: Tank Resting on Ground   Figure 25: Underground Water Tank 

 

 

Comparison of Tanks 

 

Rectangular Tank

•For smaller 
capacities, we go 
for rectangular 
tanks.

Circular Tank

•For larger 
capacities, we go 
for circular tanks.

Intze Tank

•Intze tank is 
constructed to 
reduce the project 
cost because lower 
dome in this 
construction resists 
horizontal thrust.

Prestressed Tank

•For bigger tanks, 
prestressing is the 
superior choice 
resulting in a 
saving of upto 
20%.

Figure 26: Elevated Water tank 
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Design Considerations 

The UG water tank has three basic components; i.e., top slab, sidewalls and base slab 

 The top slab will be designed as normal simply supported slab based on the self-weight and 

superimposed loads. 

 

 The design of sidewalls and the base slab will be based on assuming 

1. Tank full of water but no soil outside,  

2. No water inside tank but soil pressure from outside 

The other more critical condition of no water inside but saturated soil outside is avoided here because 

it might cause instability of the tank itself. Alternately, a provision must be made that the tank cannot 

be evacuated when the soil is fully saturated. 

Minimum Reinforcement 

 The minimum reinforcement in walls, floors and roofs in each of two directions at right angles 

shall have an area of 0.3 per cent of the concrete section in that direction for sections up to 

100mm, thickness. For sections of thickness greater than 4″, and less than 10″ the minimum 

reinforcement in each of the two directions shall be linearly reduced from 0.3 percent for 

100mm thick section to 0.2 percent for 10″, thick sections. For sections of thickness greater 

than 450mm, minimum reinforcement in each of the two directions shall be kept at 0.2 per cent. 

In concrete sections of thickness 5″ or greater, two layers of reinforcement steel shall be placed 

one near each face of the section to make up the minimum reinforcement. 

 In special circumstances floor slabs may be constructed with percentage of reinforcement less 

than specified above. In no case the percentage of reinforcement in any member be less than 

15% of gross sectional area of the member. 

Minimum Cover to Reinforcement 

 For liquid faces of parts of members either in contact with the liquid (such as inner faces or 

roof slab) the minimum cover to all reinforcement should be 1″ or the diameter of the main bar 

whichever is greater. In the presence of the sea water and soils and water of corrosive characters 

the cover should be increased by 0.5″ but this additional cover shall not be taken into account 

for design calculations. 

 For faces away from liquid and for parts of the structure neither in contact with the liquid on 

any face, nor enclosing the space above the liquid, the cover shall be as for ordinary concrete 

member. 

 

Design of Elevated Rectangular Water Tank in SAP 2000 Version 14: 

1. Click New Model Icon from File Menu 

2. Choose Initial Model from Defaults with units from new model initialization window. 

 Change Units (If Required) 

 Choose Grid Only 

 Quick Grid Lines Window appears 

 Check Coordinate system: Cartesian/Cylindrical. Select Cartesian Coordinate. 
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 No. of Grid Lines 

 X direction = 3 

 Y direction = 3 

 Z direction = 7 

3. Click Edit Grid Data to edit the spacing of the grid lines or to add new grid line. 

i. Check Glue to Grid Lines 

ii. Click ok 

 

4. Define Materials fc’=3.5 ksi, Beam Section = 12˝ × 15˝ & Column Section = 12˝ × 12˝ and Side 

wall thickness = 6˝, Top and Bottom slab thickness = 9˝. 

5. Define load cases by Clicking Define Static Load Case icon from define toolbar and define the 

load cases as Code. 

 

6. Draw Beam @Z = 7″ 

a. Select Beams 

i. Edit             Replicate 

ii. Give increments in Z direction 

1. dx = 0, dy = 0 & dz = 120 ″ 

2. Increment data = 4 

7. Draw Beam @Z=53 ″ 

a. Select Beams 

i. Edit             Replicate 

ii. Give increments in Z direction 

1. dx = 0, dy = 0 & dz = 72″ 

2. Increment data = 1 

8. Set Elevation view 

a. Draw Column clicking Draw Frame/ Cable Element from Side Toolbars 

b. Column Bottom to Top i.e @z=0 ″ to @z=53 ″) 

9. Set Elevation view- 1, 3, C, A  

a. Draw wall of Water tank by Defined Slab. 

10. Select Wall of water tank of elevation 3 & C. 

a. Assign           Reverse Local 3 Axis             Keep Assigns in Same Global Directions           ok 

11. Select Water tank Walls 

a. Edit               Divide Areas                Divide Area Based on Area Edges              Intersections 

of Visible Straight Grid Lines With Area Edges. 

b. Edit               Divide Area Into Object of maximum Size           mesh size of 1′×1′ 
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c. Ok 

12. Select Water tank walls (Select in such a way that only the joint points are selected) 

a. Define             Joint Patterns             Add 

b. Assign               Joint Pattern              Set Pattern name already defined 

c. A = B = 0; C= -1 & D = Height of the top point of the water level (For this example, D = 

53′. 

d. Restrictions: zero negative values 

e. Ok 

13. Assign          Area Loads           Surface Pressure        

a. Load Pattern name = LL 

b. Select unit in lb-ft 

c. Assign pressure by joint pattern 

d. Use a multiplier of 62.4 lb/ft3 

e. Select bottom face as load face. 

14. Define Slab of 9 inch thickness 

a. Draw Bottom slab of the water tank using side toolbar “Draw Rectangular Element”. 

 Keep in mind that water pressure on the side wall will be live load and on the bottom of the 

tank will be dead load. 

b. Select bottom slab             Assign               Area Loads               Uniform (shell) 

c. Assign a dead load of 374.4 psf (6×62.4 = 374.4 psf) in gravity direction 

15. Select Bottom slab of Water tank. 

a. Edit               Divide Areas                Divide Area Based on Area Edges              Intersections 

of Visible Straight Grid Lines With Area Edges. 

b. Edit               Divide Area Into Object of maximum Size           mesh size of 1′×1′ 

c. Ok 

16. Draw Top slab of the water tank using side toolbar “Draw Rectangular Element”. 

a. Slab thickness = 9″ 

b. Select bottom slab             Assign               Area Loads               Uniform (shell) 

c. Assign a dead load of 55 psf in gravity direction 

d. Assign a live load of 25 psf in gravity direction 

17. Select Bottom slab of Water tank. 

a. Edit               Divide Areas                Divide Area Based on Area Edges              Intersections 

of Visible Straight Grid Lines With Area Edges. 

b. Edit               Divide Area Into Object of maximum Size           mesh size of 1′×1′ 

c. Ok 

18. Select all from side tool bar. 

a. Edit             Edit Lines             Divide Frames             Break at Intersections 

19. Assign             Load Patterns              Assign EQx & EQy just like building problem              Change/ 

Modify 

20. Select All   

a. Assign            Frame             End (Length) offsets           Select automatic from connectivity 

21. Design          Start Concrete Design/ check of Structure 

a. View Reverse Overwrites             Framing Type           Sway Intermediate 

22. Design            Concrete Frame Design          View/ Reverse preferences           ACI 318-99  

23. Select all               View/ Reverse Performance 

24. Run Analysis 
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Figure 27: Elevated Water Tank Model 

 

 

 

Figure 28: Elevated Rectangular water Tank 
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